Configuración de OpenWrt Kamikaze en modo Cliente y AP a la vez

Desde hace unos tres años vengo usando un router Linksys WRT54G flasheado con el firmware OpenWrt. Lo uso para conectarme como cliente de otro punto de acceso que me provee la conexión a Internet.

También tengo otro Linksys WRT54GS que lo usaba más que nada para cacharrear y como centralita de VoIP usando Asterisk.

Bien, pues el otro día este último sufrió, digamos, una de mis terribles metidas de manos y no arrancaba, así que aproveché para probar la nueva versión de OpenWrt, a la que han llamado Kamikaze (versión 7.07 en el momento de escribir esto).

Lo primero que me llamó la atención fue el hecho de que ahora la configuración no se guarda en NVRAM, sino que ésta se guarda en ficheros dentro de /etc/config. Lo malo de esto es que no puedes actualizar el firmware sin perder la configuración, pero vamos, yo de todas formas hacía copia de /etc por si las moscas, así que pienso que la ventaja de tenerlo todo en ficheritos fáciles de entender supera al inconveniente.

Lo siguiente que me llamó la atención leyendo la aún escasa documentación (aunque seguro que pronto el wiki estará hasta arriba) es que se pueden tener varias SSIDs con un solo punto de acceso, y lo mejor, ¡se puede usar en modo cliente y AP (Access Point) a la vez!. Todo esto dependiendo del chip:

Chip Broadcom (el que tiene mi router):

  • 1 cliente y de 0 a 3 AP.
  • de 1 a 4 AP.
  • 1 en modo adhoc

Chip Atheros:

  • 1 cliente y de 0 a 4 AP.
  • de 1 a 4 AP.
  • 1 en modo adhoc

Así que me puse manos a la obra y ¡a cacharreaaaarrr!. :-)

Lo primero que probé fué a tener configuradas dos SSID (dos redes wireless, para entendernos), una privada protegida por WEP y otra abierta. Resumiendo y para no aburrir aún más, funciona. La única pega es que como comparte el BSSID (la dirección MAC de la tarjeta wireless) pueden haber problemas para que algunas tarjetas receptoras detecten las dos redes, así que hay que configurar a mano la que no se “vea”, como si estuviera oculto el SSID. La configuración para conseguir esto, o cómo flashear el router no es el cometido de esta entrada, así que recomiendo la lectura del Wiki de OpenWrt donde está todo perfectamente documentado.

Ahora vamos con lo que me interesaba, que es configurar el WRT en modo cliente como hasta ahora, y además configurarlo como un AP de una red WEP para usarlo con la Nintendo DS. Sí, ya sé que WEP es inseguro, pero es que la DS no soporta WPA.

Fichero /etc/config/network


#### VLAN configuration
config switch eth0
        option vlan0    "1 2 3 4 5*"

#### Loopback configuration
config interface loopback
        option ifname   "lo"
        option proto    static
        option ipaddr   127.0.0.1
        option netmask  255.0.0.0

#### LAN configuration
config interface lan
        option type     bridge
        option ifname   "eth0.0"
        option proto    static
        option ipaddr   192.168.2.254
        option netmask  255.255.255.0

#### WAN configuration
config interface        wan
        option ifname   "wl0"
        option proto    dhcp

Fichero /etc/config/wireless


config wifi-device  wl0
        option type     broadcom
        option channel  11

config wifi-iface
        option device   wl0
        option network  wan
        option mode     sta
        option ssid     Internet
        option encryption       wep
        option key 1234567890

config wifi-iface
        option device   wl0
        option network  lan
        option mode     ap
        option ssid     Privada
        option encryption wep
        option key 1234567890
        option hidden   0

Y ya está… tan fácil como eso. :-)

Acerca de SKaRCHa

Soy Antonio Pérez y esta es mi página personal. Aquí podrás encontrar de todo un poco. Hablo de lo que me gusta, de lo que me pasa o de lo que encuentro interesante... ;)
Esta entrada fue publicada en Linux, Tecnología, Trucos y etiquetada , , , , , , , , . Guarda el enlace permanente.

8 respuestas a Configuración de OpenWrt Kamikaze en modo Cliente y AP a la vez

  1. Martín dijo:

    Qué interesante :)

    Yo también tengo un WRT54GL y siempre quise instalar OpenWRT, pero por vagancia acabé instalando el DD-WRT que ya viene todo hecho. Bueno, por vagancia, y porque no soy el único que usa la red :(

  2. SKaRCHa dijo:

    Gracias Martín.

    La verdad es que el DD-WRT está muy bien, de hecho yo se lo he instalado a un par de amigos. La primera vez que lo vi me dejó sorprendido de la cantidad de opciones que lleva.

    Pero claro, para mi me gusta más instalar uno así básico, que me deja más espacio “en disco” y memoria RAM libre para instalarle lo que yo quiera.

  3. Kiwi dijo:

    Me ayudó bastante tu artículo Skarcha, “lo encontré” en el momento oportuno, yo también me decidí por Kamikaze y no sabía que se podían definir varias redes con el mismo adaptador.

  4. ma dijo:

    Tengo una red wifi libre o abierta a la que accedo con cualquier pc(la red no tiene ninguna seguridad y no puede acceder al router). Desde la pc comparto la conexion wifi a un red cableada la cual conecto a un router inalambrico para poder acceder con otras pc.
    Con wrt54 podria hacer como cliente y como access point para evitar enceder la compu?

  5. Omar Sánchez G. dijo:

    Buenas a todos, estoy haciendo pruebas con el OpenWrt y la verdad ando muy perdido con las configuraciones de PPPoE, bridge y Vlan , acabo de empezar a hacer pruebas pero no entiendo mucho de como deban de ir dichas configuraciones; agradecere infinitamente quien me pueda hechar la mano.
    Dejo mi mail: omar.aquelarre@gmail.com

    Saludos.

  6. Hello there, just doing some research for my Linksys website. Can’t believe the amount of information out there. Not what I was looking for, but great site. Take care.

  7. Bassboy dijo:

    Dispongo de un WRT160NL con OpenWRT al que le he instalado una RTL8187L por el puerto usb. De tal forma que tengo dos dispositivos wifi en el router.

    Interfaz wifi router —> Radio0
    USB Alfa 500mw —–> Radio1

    Intento que conecte como cliente el dispositivo Radio1 con esta config:

    essid: Essid1
    clave: Clave1
    encryp: WEP

    IP: 192.168.1.254
    MÁSCARA: 255.255.255.0
    GATEWAY: 192.168.1.1
    DNS-SERVER: 192.168.1.1

    Y que actue como Punto de Acceso con esta config:

    essid: Essid2
    clave: Clave2
    encryp: WEP

    IP: 192.168.3.1
    MÁSCARA: 255.255.255.0

    Todo esto de tal forma que todos mis equipos se conectan a la red 192.168.3.0 por Ethernet, dispongan de acceso a internet (192.168.1.1), y entre ellos, pero….. que no puedan accederse desde la red 192.168.1.0.

    Agradecería cualquier ayuda….. sería genial un tutorial o al menos los archivos de configuración:

    /etc/config/wireless
    /etc/config/network

  8. SKaRCHa dijo:

    Hola Bassboy,

    Siento no poder ayudarte con eso. Creo que lo ideal sería que te pasases por los foros de OpenWRT:

    https://forum.openwrt.org/

    ¡Suerte!

Los comentarios están cerrados.