Archivo de la etiqueta: castellano

La palabra más bonita del castellano

Hoy he propuesto una palabra para participar en un concurso (por llamarlo de alguna forma) con el que se pretende elegir la palabra más bonita del castellano.

Yo no es que sea un apasionado de la lengua (según la acepción 2 del RAE, que os veo venir :)), porque no leo nada de literatura, pero símplemente hay palabras que me gustan como suenan, y una de ellas es la que he propuesto… total, si todo el mundo puede aportar alguna, ¿por qué no voy a hacerlo yo?… :)

Mi palabra propuesta es zozobra. Y lo dicho, sólo porque me gusta como suenan esas zetas ahí… :)

En la web del concurso cuentan de vez en cuando con algunos invitados especiales, los cuales proponen sus propias palabras. Pero no os asusteis, aquí no es como en la tele, que los usuarios especiales son Ramoncín, la ganadora del último Gran Hermano o el “famoso” de moda en los programas de cotilleo. :D

Así que nada, animaos a participar vosotros también, o votad las palabras que más os gusten.

Problema con la traducción al español de WordPress

Desde que tengo el blog lo he tenido en castellano usando la traducción que nos brindan desde WordPress-es, y sin problemas… hasta el otro día, en que cambié de empresa de hospedaje…

Antes lo tenía en GetYourHost, pero he cambiado a WebHostingBuzz… no porque me fuese mal, sino porque con este último por un poco más de dinero obtengo bastante más que con el primero.

Todo fué perfecto el cambio, excepto una cosa… el tablero/dashboard de mi WordPress no estaba en español, permanecía en inglés… :(

Probé de todo… volver a subir el fichero de lenguaje, volver a subir el wp-config.php asegurándome que todo estaba bien, etc, etc… Hasta probé incluso a montar un WordPress limpio en otro directorio, y tampoco funcionaba… Esto último ya me hizo pensar que el problema iba por otra parte… como una versión de algún software distinto entre los dos proveedores de alojamiento.

Bien, pues después de buscar un ratillo por ahí, me encuentro con este comentario que me ayudó bastante.

En estas líneas del fichero wp-includes/gettext.php está el secreto:


// $MAGIC1 = (int)0x950412de; //bug in PHP 5
$MAGIC1 = (int) - 1794895138;
// $MAGIC2 = (int)0xde120495; //bug
$MAGIC2 = (int) - 569244523;

Esas dos que están comentadas parece que hay que descomentarlas si usas PHP 5, debido a un bug en éste.

En GetYourHost usan PHP 4.3.10 y todo funcionaba perfecto. En WebHostingBuzz usan PHP 4.3.11, y no funciona…

Por probar, descomento esas líneas haciendo creer a WordPress que tenemos el bug del PHP 5, por lo que quedaría así:


$MAGIC1 = (int)0x950412de; //bug in PHP 5
// $MAGIC1 = (int) - 1794895138;
$MAGIC2 = (int)0xde120495; //bug
// $MAGIC2 = (int) - 569244523;

Cuál es mi sorpresa que funciona… así que con la versión 4.3.11 de PHP también hay problemas… algo deben haber cambiado de la 4.3.10 a la 4.3.11.

En fin… Arreglado queda… ;)